We are continuing to monitor for any further issues.
Posted Sep 02, 2024 - 16:16 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2024 - 16:14 CEST
Investigating
We have received user reports of blank pages and / or slow performance on the conversation details pages. Our team is actively investigating the issue.